Installing Wygwam on ExpressionEngine 2.x


Hits: 6481  

Wygwam is powered by CKEditor. It’s fast, accessible, and produces clean, semantic markup.

You need ExpressionEngine 2.x with PHP5 to install Wygwam on web server 😉
Find a latest & stable version here.. http://pixelandtonic.com/wygwam/releasenotes

Instructions
1. Upload the ee2/third_party/wygwam folder to system/expressionengine/third_party/
2. Upload the themes/third_party/wygwam folder to themes/third_party/
3. Install the fieldtype in Add-Ons → Fieldtypes
4. While installing, choose to install the as module also
5. Enter License for Wygwam
6. Create a new channel field for news or pages
7. Use shortcode {wygwam} while displaying in front end in template files 😉

Admin -> Channel Administration -> Channel Fields -> About / News -> Create a New Channel Field

Type = Wygwam
Field Label = Wygwam

Editor Configuration: If you select “Yes”, Wygwam won’t initialize CKEditor until the field is clicked on.

Refer below gallery for general idea about Wygwam Plugin

Published by

Sandeep Verma

I’m an Entrepreneur. I’m proud to work as Blogger, LAMP Programmer, Linux Admin, Web Consultant, Cloud Manager, Apps Developer, Searcher. Concentrate > Observe > Imagine > Launch